Mathematica 9 is now available

Workbench 疑难解答

问:Workbench 可用于哪些 Wolfram 产品?
问:我需要安装什么软件才能使用 Workbench
为了使用 Workbench 您必须已经安装 Mathematica 或任何其它 Workbench 兼容的 Wolfram 产品。
问:Workbench 使用何种技术?
Workbench 是建于 MathematicaEclipse 之上。它大量使用在 Mathematica 和 Java 间提供透明通讯的 Mathematica 工具包 J/Link
问:什么是 Eclipse?
Eclipse 是一个用于集成开发环境开发的领先平台。Eclipse 是平台独立的且建于一个扩展机制之上,包括诸如插件等模块。Eclipse 有大量免费插件和商业插件,便于您执行各种不同的任务。这包括对 Java、C、C++ 和 Fortran 等语言的支持,以及对 HTML、XML、 UML 和许多网络技术的支持。关于可用插件的更多信息请参见 Eclipse Marketplace。许多公司诸如 IBM、Nokia、Borland 和 Adobe 都把技术建于 Eclipse 之上。
问:Workbench 是如何使用 Eclipse 的?
Wolfram Workbench 是 Wolfram 品牌的 Eclipse 版本,其中包含许多用于 Mathematica 和其它 Wolfram 技术的插件。您也可以将 Workbench 插件安装于独立的 Eclipse 副本中。如果只需要插件,在选择 Workbench 下载平台时,请选择 "Eclipse" 选项。与 Wolfram Workbench 使用 Eclipse 内核一样,第三方插件的安装和运行就像在 Eclipse 中安装一样。
问:受支持的 Eclipse 版本有哪些?
Wolfram Workbench 2 包括一个 Eclipse 3.5 的品牌版本;同时,它也可以以插件形式安装到现有的 Eclipse 3.4 至 3.8 版本上。目前尚不支持 Eclipse 4.2。
问:如果我在运行多语言开发的项目,我可以使用 Workbench 来管理工作流程吗?
可以的。对于多语言开发,Workbench 相当有用,因为 Eclipse 有相当大范围的插件。
问:Workbench 支持何种平台?
Workbench 支持 Windows、Mac OS X、和 Linux。
问:Workbench 支持哪些版本的 Mathematica
Workbench 支持 Mathematica 6 或更高版本,以及包括这些 Mathematica 版本的其它 Wolfram 产品。
获取 Workbench —有 Premier Service 的免费


Select Language: enjaes